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Session 3.C Task 3-B 

Hazard analysis of cyclone flooding in 
Bangladesh  
Part B  Flood hazard analysis of the Banskhali area for 

different return period of the cyclone events  
Expected time:  3 hours 

Data:  Data file: Riskcity exercises/exercise03C1/data 

Objectives:  After this exercise you will be able to: 

 - display satellite images of the Baskhali study area; 

 - display ground photographs of selected points; 

 - display the available segment and point data layers; 

 - interpolate the point elevation data to an elevation raster map; 

 - understand and apply cyclone flood impact modeling for different return periods 
using ILWIS script language.  

                            
 

 
1. Introduction 

During the years 1797 to 1991, Bangladesh was hit by 59 severe cyclones, of which 32 
were accompanied by storm surges. Concerning 20 of these cyclones, information for the 
whole of Bangladesh is stored in the ILWIS table Landfall on Wind Speed, Wind Surge 
height, number of Casualties, Tidal Height during the event, etc. 

Despite the fact that the Bangladesh Government issued warnings of the impending 
flooding, for the April 1991 cyclone, through its Cyclone Preparedness Program, and 
about 3 million people moved to safety, many inhabitants remained behind to protect 
their property.  

During this disaster an estimated 138.000 people were killed and large numbers of 
houses, agricultural lands and infra-structural works were destroyed. Hundreds of 
schools were damaged and seven to eight thousand vessels were lost. Almost every 
bridge and culvert in the area was damaged and roads were washed out. 

Within two days government air drops of food and medicine started, but they were 
hampered by continuing bad weather associated with the storm. Nearly two weeks had 
passed before massive international aid could react to the disaster and it was many 
months before the area returned to normal. 

The Banskhali study area is situated in the East of Bangladesh, South of the city of 
Chittagong. Maps and attribute tables are given of the geomorphology, village 
population, the Union-districts, roads, embankments, cyclone shelters, and the elevation 
of the terrain with centimeter accuracy. Also available are Landsat Thematic Mapper and 
(scanned) SPOT panchromatic satellite images. For a general introduction you can make 
use of a geomorphological overview map of the whole coastal zone of Bangladesh as well 
as ten ground photographs of the Banskhali area. 

In Part B of Task 3 you will first display the different data layers of the Banskhali area. 
Also field photographs from the ground can be displayed. Next you rasterize the 
segment and vector maps for further map calculation and also perform point 
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interpolation to create the elevation map.. Finally flood hazard maps are created using 
ILWIS script for different return periods, as calculated by Khan (1995). 

Some GIS files are derived from: 
− Sirajur Rahman Khan (1995) - “Geomorphic Characterization of cyclone hazards along the 

coast of Bangladesh”, ITC - MSc study. 

-  See also the table of contents. 

 

Table 1:  

Cyclone Surge Heights for different coastal tidal zones and different return periods 
 

 Return  Period Entire coast  Zone 1  Sundarban  Zone 2  Noakhali  Zone 3  Chittagong
Years Meters Meters Meters Meters

5 4 4.1 4.5 3.7
10 4.7 5 5.6 4.1
20 5.4 5.7 6.2 4.7
50 6.1 6.6 7.1 5.1

100 6.7 7.1 7.8 5.6

1
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Figure 1  

Three coastal zones of Bangladesh based on tidal amplitude. Zone 1: 
low; zone 2: medium & zone 3: high. 
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2. Exploring the input data 

In the data catalog you see the icons of the available input data for this case study.  

‐ In Part A of the exercise on cyclone flood hazard modeling you displayed already 
the data for the whole of Bangladesh.  

‐ In Part B we are going to use also the data from the Banskhali area.  

 

Name Type Meaning 

Bdesh Raster map Hill-shading map made out of a low resolution 
DEM of the whole of Bangladesh 

Bdgeom Polygon map Main Geomorphological Units of Bangladesh. 

Landfall Table Information on Cyclone Events, Causalities, etc. 

Landform Polygon map Landforms, including Rivers and Dikes. 

Baskhali data for part 2 of the exercise: 

Shelter Point map Locations of Cyclone Shelters. 

Roads Segment map Main- and Secondary- roads. 

Village Polygon map Villages, including a table on Population. 

Eleva Point map Point elevation in cm above mean sea level. 

Waterlin Segment map Digitized coastline of the area. 

Batm90b2->7 Raster map Landsat-TM image 31-10-1990, bands 2, 3, 4, 
5 and 7. 

Baspotx Raster map 
SPOT panchromatic image, scanned from a 
paper print. 

Photos 1-10 Raster photo 
Scanned ground photographs of November 
1994 taken by M. Damen. 

 

      3. Displaying satellite images of the Banskhali area 
Of the Landsat Thematic-Mapper image of 31 October 1990 the bands 2 - 5 and 7 are 
given. The bands are geocoded and geometrically corrected.  

The raster map Batm90b453 to be made provides information on the terrain 
characteristics. From west to east you first have the sea (blue color). The beach has a 
light image tone; the wider zone in the south is a tidal flat. Clearly visible is a north-
south running river with some tributaries. In the east you find the Chittagong hills 
consisting of soft sedimentary rocks; the eroded parts have a light image tone. Other 
image tone differences are caused by various types of land use, such as homestead 
gardens, rice fields and roads. 

 
  

• Make a color composite of Landsat Thematic Mapper bands 4, 
5  & 3 for red, green and blue. Use for this: Operations > 
Image processing > Color Composite.  Use the default values 
for this.  

• Save the result as batm90b453 

• Study the colors of the image, and zoom-in at selected sites. 

• Close the map window when finished. 
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Now look at the SPOT panchromatic image with filename Baspotx. The image is from 
the 22nd of January 1994 and is scanned from a paper print and re-sampled to the 
original pixel resolution of 10 m.  

 

  
• Display the raster map Baspotx. 

• Browse through the image. Study the image characteristics 
such as grey tone and pattern. Try to recognize the homestead 
gardens of the villages, the hills, the roads, and the lower parts 
in the terrain. Zoom-in, if necessary. Do you also see the 
embankment near the coastline? 

• Look also at the map properties by selecting File > Properties. 
You now find information on the size of the map, the pixel size, 
and the domain: Image. Close the Properties dialog box. 

 

 4. Displaying ground photographs taken from point 
locations 
Ten ground photographs taken by M. Damen in 
November 1994 can be displayed. The pictures are 
intended to give an impression of the terrain and the 
cyclone shelters; the points are not always at the exact 
location from which the photo have been taken. 

 

  
• Add as new data layer to the map Baspotx the point map 

Photos. Choose an appropriate symbol size and color. 

• Select: Layers > Double Click Action > Execute Action, OK. 

• Double-click a point to display a ground photograph. Repeat 
from other photographs 

• Close the map window. 
 

 

 5. Display of the segment and point data layers  
In this exercise the SPOT panchromatic image will be combined with other data layers, 
such as the landuse (map: Village), the geomorphology (map: Landform), the roads 
(map: Roads) and the point elevation data (map: Eleva).  

 

  
• Display the map Baspotx. 

• Add as data layer the Polygon map Village.  Select: 
Boundaries Only and boundary color green. Click: OK and you 
see the boundaries of the land use in green. These are 
digitized segments. 

• Compare the map Village with your own visual interpretation. 

• Look also at the map properties by selecting File > Properties. 
Information is displayed on the map size, the Identifier domain 
Village and the number of polygons.  Note that also the table 
village is linked to the map 



Riskcity exercise Task 3-3-C Part B : Cyclone Hazard Modelling Bangladesh  
 

RiskCity exercise 3C1 – 5 
 

• Close the Properties dialog box. 

All landuse data is stored in the table Village. You can display this data using the pixel 
information window. 

  
• Open from the ILWIS Main menu the Pixel Information window 

. Select: Options > Always on Top. Make sure that this 
window is displayed next to the SPOT image and that also the 
Catalog in the Main window is still visible. 

• Drag-and-drop from the ILWIS Main window the polygon map 
Village into the Pixel Information window. Remark: You can 
also use: File > Add Map… 

• Read the table information while browsing through the village 
areas. 

• Add also the data layer Landform to the map window (polygon 
map with red boundary color). 

• Drag-and-drop polygon map Landform into the Pixel 
Information window and “browse” again through the SPOT 
image. 

 

  
• Also drag-and-drop polygon map Union into the Pixel 

Information window. Union means local district; the total 
population is given. 

• Finally add the polygon map Union (display only the 
boundaries in orange) and the segment map Roads. 

• Change the layers Union, Village, Landform and Roads in 
the list in the Layer Management dialog box by clearing the 
checkbox for each of them. The maps are not shown anymore. 

 
 

Finally, the elevation point information can be displayed as follows: 

  
• Add as new data layer to the map window the point map Eleva. 

In the Display Options window select: Attribute: Eleva_cm. 

• Choose an appropriate symbol color and size. Click an elevation 
point to display the elevation. Remark: if you click in between 
the elevation points, not the elevation but the pixel value of the 
satellite map is being displayed! 

• Drag-and-drop to the Pixel Information window the raster map 
Eleva This is the Digital Elevation Model of the area, created by 
interpolation of the individual elevation points (in point 7 of the 
exercise you can do this yourself). 

• Right mouse-click the map eleva in the Pixel Information 
window and display the Properties dialog box; read the 
information. The domain is Value. Close the box. 

• Browse through the images to know the information from the 
maps Landform and Eleva. 

• Close the map windows and the Pixel Information window.  
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6. Rasterizing the maps 
For the surge hazard modeling you need to perform several MapCalculations. For this 
you have to rasterize the maps first. 

 

  
• Rasterize the map Landform using the option Polygon to Raster in 

the Operations-list under Rasterize. Give the output raster map the 
same name. Use the Georeference  : Baspotx. 

• Repeat the same procedure for the polygon maps Union and Village 
using the same Georeference. 

• Rasterize the segment maps Waterlin and Roads. Save the 
rastermap with the same name and use for all the maps the 
georeference Baspotx. Check the results. 

 

 
7. Creation of the elevation map yourself by point 

interpolation 
 

  
• Select from the main menu: Operations > Interpolation > Point, 

Interpolation > Moving Average. Select from the point map Eleva the 
Column: Eleva_cm.  (click for this selection the small box with the 
cross in front of the map icon Eleva).  

o Use the georeference: Baspotx; and a value range: 0-1500 with a 
precision 1. Remark: the domain of the selected column is: Value 

o Select Weight function: Inverse Distance; Weight Exponent: 1 and 
Limiting Distance: 700. The output map name is Eleva.  

• Click: Show.  Overwrite the already existing file Eleva.  

 
8. Cyclone flood modelling - methodology 

 
During this part of the exercise you will make a map of the floodwater depth during the 
April 1991 cyclone in the Chittagong/Banskhali area. For this two models will be used: 

1. A surge model based on historical records of cyclone flooding in Bangladesh; and  

2. The Digital Elevation Model (DEM) of the area (this is the map eleva). 

The Surge Decay Coefficient (SDC) 
Before starting the calculations for the Surge Model, you have to find out how the 
cyclone surge depth decreases inland. This is the so-called Surge Decay Coefficient 
(SDC), which will be different for each wave height at the coast. The SDC is a function 
of the friction caused by surface forms (morphology, embankments and elevated roads) 
and land cover (houses, rice fields, homestead gardens with trees, etc.).  

The contribution to the friction of all the terrain elements to the SDC is not fully 
understood and is still under investigation. However, we know from historical records 
that in areas with low or no dikes along the coast the surge inundation depth will be 
more or less constant in the first strip along the coast. After this it will decrease until a 
certain distance inland.  
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The data from the total limit to inundation from the coastline for different Wave Heights 
have been taken from the Multi-purpose Cyclone Shelter project (MCSP, 1993) in 
Bangladesh. Some of these data for the whole coast of Bangladesh are presented in the 
Table 2 below. 

Table 2:  Relation Wave Height at coastline and Inundated area (Whole of Bangladesh)          

Wave Height at Coastline  

(meters) 

Area with Constant Surge 
Depth 

(distance from the coastline 
in meters) 

Total Inundated Area 
(distance from coast in 

meters) 

3.7 415 2000 

4.1 520 2900 

4.7 580 3900 

5.1 670 4200 

5.6 760 4400 

6.0 880 4700 

6.5 1000 5000 

Various reports of the April 1991 cyclone event in the Chittagong/ Banskhali area 
indicate a Wave Height at the coastline of about 6.5 meter; the surge extended 
approximately 5000 m. inland.  

The Wave Height included a tidal height during the time of landfall of + 1.7 meter. This 
means that the actual Wind Surge Height at the coastline in the Banskhali area was 
“only” 6.5m - 1.7m = 4.8m.  

For the modeling we take a constant surge depth of 1000 meter starting at the coastline 
(see Table 1). Further inland the surge depth decreased with the SDC  (see also Figure 2 
on the next page). 

 
The Surge Decay Coefficient (SDC) is calculated as follows: 

 

surgeconstant  with area Width - area  inundated lWidth tota
surge of endat  terrain ofelevation  Avg. - coastlineat height  WaveSDCRP =            

 

Filling in the values from Table 2 in the above equation for a wave height at the coast of 
6.5 meter, we find: 

 SDC Surge 650cm in Chitt.

  cm 
m 

− 
− 

650 267 
1000 

( ) 
(5000 ) 

cm m g  = = 0 096 . 
      

The SDC value will be used in the next part of the exercise on surge modeling  

 

DEM 

 0 cm  
1000m . from  coast 5000m . 

262m  262cm  262cm  

 650 cm  
Constant       Decay 

267 cm

 
Figure 2:  Cross section illustrating the surge decay inland of a Wave Height of 650 cm 
at the coastline 
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9. Cyclone surge modelling – Steps to be followed 
The two steps for a surge modeling of a 650 cm. high Wave Height at the coastline are 
the following: 

Step 1 

Creation of a distance map starting at the coastline to at least 5000 m. inland. The 
coastline is given in the raster map Waterlin. First we remove the sea part. After this 
we save the result as the map Codist.  

Step 2 

Creation of several maps of the Surge Inundation depth for a wave height near the coast 
of 650 cm: 

− One map from the coastline until 1000m inland, as if there is no decay and relief. 
To be saved as In650a. 

− Another map from the decay starting at 1000 m. inland and giving linear 
decreasing values until 5000 m inland, to be saved as Sdc650. 

− A map in which the values from the map Sdc650 are subtracted from the map 
In650a. This map should be saved as In650b. 

− Finally you subtract the values of the elevation map Eleva from the map 
In650b. This is the map In650c.  

− To exclude the area at more than 5000m from the sea we remove all negative 
values. The final map is the cyclone flood hazard map and should be saved as 
Haz650f.  

Step 1 – Creation of distance map starting at the coastline 
 

  
• Calculate a distance map using Waterlin as the starting map. Give 

precision 1.0. The output map is: Distance. 

• Display the result and check the image values. 
The distance calculations are also performed in the direction of the 
sea.  Exclude the sea with the formula: 

Codist:=iff(Landform=”Sea”,?,Distance)↵ 

 

Step 2 – Creation of a surge inundation map (650 cm surge) 
In this steps is explained how a surge inundation depth map for a surge height of 650 
cm. can be made. According to Table 2 is the width of the inundated area for this surge 
height 5000 meters.  

In part 10 of the exercise you will make maps for different surge heights “automatically” 
using an ILWIS script. 

 
  

• Type the following MapCalc formula in the command line to make the 
inundation map until 5000 m from the coast for a coastal wave height 
of 650 cm as if there were no decay and no relief: 

 In650a:=iff(Codist<=5000,650,0)↵ 

Save the map with domain Value and precision 1.0. Check the values. 

• Make a map of the surge decay from 1000 until 5000 from the coast. 
Type the formula: 

        Sdc650:=iff (codist>1000,0.096*(Codist-1000),0)↵ 

The formula describes that for each meter distance from the coast 

Distance calculation: 
this operation 
assigns to each pixel 
the smallest distance 
in meters towards 
user-specified 
source pixels, for 
example distance to 
schools, to roads 
etc. The output is 
called a distance 
map. Input for a 
distance calculation 
is a source map and 
optionally a weight 
map. Check the 
ILWIS guide to read 
further explanation 
about the Distance 
calculation. 
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(starting at 1000 m.) the map values will be reduced by the Surge 
Decay Coefficient (SDC). Save the map with domain Value and 
precision: 1.0. Check all the values. 

• Subtract the pixel values of the Sdc650 map from the pixel values of 
the In650a map. Save the resulting map as In650b with domain 
Value and check the pixel values. 

• Subtract the elevation map from In650b. Save the map as In650c 
with domain Value and check the pixel values. As you will see, some 
pixels in the East have a negative value. 

• Finally exclude the negative values in In650c, which make no sense for 
further calculations. The final hazard map is: 

       Haz650f:=iff(in650c<=0,0,in650c)↵ 

• Display the map and check the pixel values. Close the map. 

 

10. Cyclone surge modelling using ILWIS script 
In this exercise you will make several hazard maps per return period. In the maps you 
include per return period, the extend of the flooded area and the flood depth per pixel 
(magnitude of the hazard). 

The procedure is as follows:  

a. For each recurrence interval the corresponding Surge Decay Coefficient has to be 
calculated using the data from Tables 1 and 2. Do not include the tidal influence in 
the calculations. 

b. Flood Hazard maps per return period have to be made (inundation depth maps). This 
can be done relatively fast by using the ILWIS script option. With a script you make 
a sequenced list of ILWIS operations, equivalent to a batch file. In the script 
dialogue box, type your lines of calculations and operations. The parameters in a 
script must be written as %1, %2, %3, etc. The script can be run from the command 
line in the Main window of ILWIS. 

c. Name the final hazard maps Hazrety (ret = return period). 

a. Calculation of the Surge Decay Coefficient (Chittagong zone) 

Example: Return period 5 years. Corresponding Wave Height at the coast: 370 cm.  
 

  
• Calculate SDC for all return periods using the SDC formula. 

First you have to fill in all data in the table below using the information 
from the tables 1 and 2. 

• After this, you estimate the average elevation at the end of the flooded 
area:: 

First make a map of the terrain elevations at the total flood distance 
from the coast using the maps Codist and Eleva (or DEM).  
Example MapCalc for the elevations at approx. 2000m from the coast 
(strip of 10m wide):  

elev370:=iff(inrange(codist,1995,2005),eleva,?) 

• Next display the histogram of the map elev370, and read at the 
bottom of the histogram table the Average value (Avg).  

• Calculate the value of SDC using a pocket calculator and the existing 
function SDC. Write the result manually in Table 3. 

• Repeat this for the other maps; fill in the table below. 
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Table 3: Table to be completed manually 
 

Return 
period 

Wave height 
Chittagong 

 (cm) 

Area under 
const. Surge 

(meters) 

Inundated  
Area 

 (meters) 

Avg. elev. at 
end of surge 

(cm) 

SDC  
(cm/m) 

5 yr. 
370 415 2000 274 0.061 

10 yr. 
     

20 yr. 
     

50 yr. 
     

b. Flood hazard mapping per recurrence interval using ILWIS 
script 

 

  
• Open the script: Surge. 

• Study the Script file (which is printed below). Do not change it! 
The Script file gives all the steps for the calculation of the surge 
inundation depth (as explained in section 3.5). 

• Exit the script file. 

Script file: 

%1:=iff(Codist<=%2,%3,0) 

%6:=iff(codist>%5,%4*(Codist-%5),0) 

%7:=%1-%6 

%8:=%7-Eleva 

%9:=iff(%8<=0,0,%8) 

Explanation :      

 % 1 : flood map as if there were no decay and relief (inxa.mpr) x:flood height 

% 2 : the width of the inundated area 

% 3 : the flood wave height at the coastline (surge plus tidal height) 

% 4 : the value of the Surge Decay Coefficient (SDC) 

% 5 : the width of the area with constant flood depth (strip near the coast) 

% 6 : the map Sdcx.mpr (reduction by the SDC) 

% 7 : the map Inxb.mpr (x: Wind Surge height at the coastline) 

% 8 : the map Inxc.mpr (x: Wind Surge height at the coastline) 

% 9 : the final hazard map Hazrety.mpr (ret: return period of the Wind Surge)  

Landform, Eleva, Codist: existing maps used for the calculations 
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• Type in the command line of the main window the following for the 5 

year return interval with a Wind Surge height along the coast of 370 
cm (values from first row in the above table): 

 Run Surge In370a 2000 370 0.061 415 Sdc370  In370b In370c 
Haz05y 

• Meaning: run surge %1 %2 %3 %4 %5 %6 %7 %8 %9  

• Press Enter and wait until the calculations have been finished.  Now the 
maps In370a-c, Sdc370 and final hazard map  Haz05y are made. 

 
For the flood hazard modeling for the different recurrence intervals we first have to 
make a table with all the data necessary to run the script files. For the Wave Heights at 
the coast we take the Storm Wave heights per return period (Table 3.1) and do not take 
into account the unknown effects of tidal variations. 
 
Table 4: Table to be completed, containing input parameters for the script 
 

 % 5 yr. 10 yr. 20 yr. 50 yr. 

Wave height at coast (cm)
x 

(cm) 
370    

Map: Inxa % 1 In370a    

Width of inundation (m) % 2 2000    

Flood height at coast (cm) % 3 370    

SDC % 4 0.061    

Width of constant surge (m% 5 415    

Map: Sdcx % 6 Sdc370    

Map: Inxb % 7 In370b    

Map: Inxc % 8 In370c    

Map: Hazrety % 9 Haz05y Haz10y Haz20y Haz50y 

 

  
• Create the formulae to be typed in the command line of the main 

window for return intervals of 10, 20 and 50 years: 

 Flood hazard map with 10 year return interval - Haz10y: 
 
Run Surge ____  ____  ____  ____  ____  ____  ____  ____  ____ 
 %1   %2  %3    %4     %5     %6     %7     %8      %9  

 Flood hazard map with 20 year return interval - Haz20y: 

 Run Surge ____  ____  ____  ____  ____  ____  ____  ____  ____ 
 %1   %2  %3    %4    %5     %6       %7     %8     %9 

 Flood hazard map with 50 year return interval - Haz50y: 

• Run Surge ____  ____  ____  ____  ____  ____  ____  ____  ____ 
            %1     %2    %3 %4    %5     %6  %7      %8  
%9 

• Type the first in the command line and press: Enter. Make sure that 
there is always one space in between the parameters.  

• Repeat this for the other formulae.  

• Check the hazard maps: Haz05y, Haz10y, Haz20y and Haz50y. 
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